iiQ Academy Course Access
Incident Report for Incident IQ Platform Status
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 00:04 EDT
Identified
We are currently investigating an issue preventing access to some courses with Incident IQ Academy.
Posted Mar 24, 2023 - 09:53 EDT
This incident affected: Support Resources (iiQ Academy).