Slow page loading and delayed sync job processing
Incident Report for Incident IQ Platform Status
Resolved
Site responsiveness and all platform performance metrics have been normal since around 10:15 AM. Current mitigation steps are working as intended and we are working on additional improvements to prevent this situation from occurring going forward. We completely understand how critical the Incident IQ platform is to supporting K-12 workflows and appreciate everyone's patience as we worked to resolve this issue.
Posted Feb 07, 2023 - 13:31 EST
Monitoring
Our platform monitoring tools indicate expected stability and responsiveness across all customer sites. Page updates and loading times are back within expected speeds. We are continuing to monitor the situation to ensure mitigation efforts continue to be effective. Please contact our support team if you are encountering any issues with site responsiveness.
Posted Feb 07, 2023 - 11:03 EST
Investigating
We are experiencing some intermittent site responsiveness issues that are causing slow page loading times and error messages during ticket submission. Our Engineering Team is currently investigating the cause and working on a solution. We will provide updates here as soon as they are available. Apologies for the inconvenience and thanks for your patience.
Posted Feb 07, 2023 - 08:57 EST
This incident affected: Platform.