Slow Page Loading
Incident Report for Incident IQ Platform Status
Resolved
Root cause investigation is underway and details will be posted here when available. Thanks for your patience as we worked through the site performance issue earlier this morning.
Posted Aug 19, 2022 - 17:14 EDT
Monitoring
We have identified the issue and implemented a solution. Site responsiveness has returned to normal and login issues have been resolved. We are continuing to monitor all platform status dashboards as Incident IQ up-time is our highest priority. Some background server jobs like email alerts may be delayed for the next 20 minutes as the backlog clears.

Please contact our support team if you observe any lingering issues. Our engineering team is working on a full root cause investigation and more details will be provided here once available. We understand how important Incident IQ is to school operations and especially during this time of year. Apologies for this inconvenience and thank you for your patience.
Posted Aug 19, 2022 - 12:35 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 19, 2022 - 12:26 EDT
Investigating
We are experiencing some site responsiveness issues that are causing slow page loading times and intermittently impacting ticket creation and editing of assets. Our Engineering Team is currently investigating the cause and working on a solution. We will provide updates here as soon as they are available. Apologies for the inconvenience and thanks for your patience.
Posted Aug 19, 2022 - 11:10 EDT
This incident affected: Platform.