Site Access and Login Issues
Incident Report for Incident IQ Platform Status
Resolved
Between 11:25AM and 12:05PM EDT, we experienced a momentary communication issue with one of our databases. We expect issues like this to be mitigated or automatically resolved by leveraging our built-in redundancy measures. We believe an issue with an upstream provider may have caused this process to fail unexpectedly. We had a single server cluster that did not automatically recover. Our Engineering team has added additional server clusters and spare capacity to ensure site responsiveness is not impacted should we experience the sequence of events in the future.

With that said, we continue to operate at our normal state of platform healthiness and will continue close monitoring of all system performance metrics. We understand that Incident IQ is a critical piece of K-12 workflows and apologize for the system downtime. Thank you for your patience as we worked to resolve this issue.
Posted Sep 11, 2023 - 17:59 EDT
Monitoring
Site access and responsiveness should be restored to normal operation. If you encounter any ongoing issues, please report them via email to support@incidentiq.com. Root cause investigation is ongoing and we are actively monitoring all internal performance logs and dashboards to ensure site performance remains optimal. We will continue to provide additional updates here as information is available and validated. Apologies for this interruption in service.
Posted Sep 11, 2023 - 12:23 EDT
Investigating
We are experiencing site responsiveness issues that are causing intermittent login problems. Our Engineering Team is currently investigating the cause and working on a solution. We will provide updates here as soon as they are available. Apologies for the inconvenience and thanks for your patience.
Posted Sep 11, 2023 - 11:34 EDT
This incident affected: Platform.