Intermittent issues displaying and filtering assets

Incident Report for Incident IQ Platform Status

Resolved

This incident has been resolved.
Posted May 17, 2025 - 21:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 17, 2025 - 13:15 EDT

Identified

We've identified intermittent issues with fee tracker app, as well as, displaying and filtering on certain elements in assets explorer. There is no loss or impact to the underlying data. Thanks for your patience as our Engineering team works to resolve the issue as soon as possible.
Posted May 17, 2025 - 12:30 EDT
This incident affected: Platform.