Delays in mail server processing
Incident Report for Incident IQ Platform Status
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 08:51 EST
Monitoring
Our Engineering team has successfully deployed back-up services to mitigate processing delays with our primary mail service provider.
The backlog of delayed email notifications has been cleared and all notifications are sending on schedule as expected. Thanks for your patience as we worked to resolve this issue. Please contact our Support team if you have any questions.
Posted Feb 21, 2023 - 13:33 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 21, 2023 - 12:14 EST
Identified
We are currently investigating a performance issue with our email service provider. No data is lost, but you may intermittently experience delays with outbound email notifications and inbound email to ticket creation workflows. We are working with our vendor and will provide additional updates here as soon as possible. Thank you for your patience as we work through this issue.
Posted Feb 21, 2023 - 12:11 EST
This incident affected: API and Email Notifications and Alerts (mailgun Inbound email processing, mailgun Outbound Delivery, iiQ Email Processing).